r1 - 18 Dec 2006 - 08:09:49 - RandyLetnessYou are here: OSAF >  Journal Web  >  ContributorNotes > RandyLetnessNotes > CosmoPostgresConfiguration
Recently, changes have been checked into the trunk to allow Cosmo to be configured to run against a PostgreSQL 8.2 database. Here are instructions for configuring Cosmo to run on PostgreSQL:

  1. Download PostgresSQL JDBC driver (http://jdbc.postgresql.org/download.html). Make sure you download the latest JDBC 3 driver.
  2. Copy jdbc driver jar to osaf-server-bundle-0.6-SNAPSHOT/tomcat/common/lib
  3. Create database on PostgresSQL server. Make sure you specify UTF8 encoding.
  4. Edit osaf-server-bundle-0.6-SNAPSHOT/etc/cosmo.properties. Comment and Uncomment the relevant properties for Postgres ( cosmo.hibernate.dialect and cosmo.hibernate.sql.booleanStringValue).
  5. Edit osaf-server-bundle-0.6-SNAPSHOT/tomcat/conf/server.xml. Comment the current database Resource definition and uncomment the sample postgres one and configure to match your database.
  6. Startup Cosmo

-- RandyLetness - 18 Dec 2006

Edit | WYSIWYG | Attach | Printable | Raw View | Backlinks: Web, All Webs | History: r1 | More topic actions
 
Open Source Applications Foundation
Except where otherwise noted, this site and its content are licensed by OSAF under an Creative Commons License, Attribution Only 3.0.
See list of page contributors for attributions.